Linux Bash发现重大漏洞

GNU Bourne Again Shell (Bash)是Linux和Unix系统中广泛使用的命令行Shell。最近发现的bash重大漏洞允许攻击者运行任意代码,从而接管系统。由于Bash使用广泛,而此漏洞的利用难度极低,可以预见近期将有大量基于此漏洞的攻击发生。

受此漏洞影响的系统包括:

  • RedHat
  • CentOS
  • Ubuntu
  • Debian

受影响的程序包括:

  • Apache
  • SSH
  • DHCP
  • CUPS

可以在shell中运行以下测试代码检查系统是否有此漏洞:

# env x='() { :;}; echo vulnerable' bash -c "echo this is a test"

如果出现以下内容,则表示漏洞存在:

vulnerable
this is a test

解决办法:
RedHat和CentOS系统可以通过以下命令将bash升级到bash-4.1.2-15.el6_5.1:

# yum update bash

升级完成之后必须重启系统!

Ubuntu用户可以通过以下命令升级bash:

# apt-get install bash

bash升级完成之后再次运行测试代码,如果出现以下提示,则表示漏洞已经修复好了:

bash: warning: x: ignoring function definition attempt
bash: error importing function definition for `x'
this is a test

此漏洞极易被用于攻击网站,目前已有知名网站被攻陷,所有运行Apache的服务器都应该马上更新bash程序。

(完)

26 2014

使用Geo-replication实现GlusterFS异地数据同步

GlusterFS的Geo-replication是一种异地数据同步技术,它可以几乎实时地把GlusterFS的卷(Volume)通过网络同步到异地,主要应用于GlusterFS的数据备份和灾难恢复。
本文主要介绍Geo-replication的安装和设置。两台服务器master.quenywell.com和slave.quenywell.com分别用作Geo-replication的主服务器(Master)和从服务器(Slave)。
(更多…)

28 十二 2013

使用LDAP进行Apache登录验证

LDAP可以记录诸如名称、公司、部门、地址、电话号码、Email、用户名和密码等信息,而且允许几乎所有操作系统平台上的应用程序从中获取信息,因而被广泛应用于企业内部,用以集中管理企业信息。
本文主要介绍LDAP应用的其中一个例子:使用LDAP进行Apache登录验证,有关LDAP服务设置部分请参考LDAP服务器快速安装指南
(更多…)

21 十二 2013

解决Webex无法分享桌面和使用语音的问题

系统从CentOS 5.x 32位升级到CentOS 6.x 64位之后,电话会议系统Webex不能正常使用了:可以参加会议,但是没法获得会议主持人分配的各种权限,没法分享桌面、文档和应用,使用本机连接语音会议时提示“The audio device is inaccessible now”。
后来发现原因是Webex对64位系统支持不够好,对应的解决办法是安装32位的Firefox和32位的JRE。
(更多…)

14 十二 2013

GlusterFS常见错误及解决方法

在安装GlusterFS的时候曾经遇到过一些错误,解决这些错误时花费了不少时间,科威网在此列举几个比较常见的,并提供相应的解决办法,希望可以帮助大家少走几步弯路,节省一些时间。

  1. mount.nfs: access denied by server while mounting…

  2. GlusterFS可以跟你所用的NFS版本有冲突,停用NFS然后重启GlusterFS或者重启服务器可以解决这个问题:

    # /etc/init.d/nfs stop
    # chkconfig nfs off
  3. requested NFS version or transport protocol is not supported

  4. GlusterFS不支持UDP协议,当你的NFS客户端使用UDP协议连接GlusterFS时就会出现这个错误,解决办法是使用TCP协议连接:

    # mount -o mountproto=tcp -t nfs server1:/test-volume /mnt/glusterfs
  5. GlusterFS: {path} or a prefix of it is already part of a volume

  6. 当你创建Volume时,使用曾经被用来创建过Volume的目录将出现这个错误。比如你曾经使用server1:/data目录创建了名叫dis-volume的卷,之后把这个卷删除了,然后又想用server1:/data创建一个名叫rep-volume的卷时,就会遇到这个错误。
    解决办法,在server1上运行命令:

    # setfattr -x trusted.glusterfs.volume-id /data
    # setfattr -x trusted.gfid /data
    # rm -rf /data/.glusterfs
    

    运行上述命令时如果出现属性不存在的错误提示,忽略即可。然后这个目录就可以重新用于创建新Volume了。

07 十二 2013